This product was discontinued on July 1st 2012, however all existing customers will continue to receive support as per their maintenance agreement. Learn more.

Interspire Knowledge Manager Requirements

Interspire Knowledge Manager is a simple to install (we offer an installation service if needed) and easy to configure PHP web server script. It requires the following:

User Requirements

  • Operating System: Windows, Mac or Linux
  • Web Browser: Internet Explorer (Windows) or any Gecko based browser such as FireFox or Safari (Windows, Mac, Linux)

Web Server Requirements

  • Operating System: Linux, Unix, Windows
  • Web Server: Apache Web Server, LigHTTPD, IIS (with ISAPI_Rewrite installed)
  • Scripting Language: PHP 5.0 or above
  • Database: MySQL 4.1 or above, Microsoft SQL Server 2000 or above, Oracle 9i or above
  • Optional: PHP's LDAP library is required to use LDAP functionality in the Enterprise edition
  • Optional: AntiWord (free) is required to index and search Microsoft Word 2003/XP documents
  • Optional: ppthtml (free) is required to index and search Microsoft PowerPoint 2003/XP documents
  • Optional: PHP's zip library (free) is required to index and search Microsoft Word/PowerPoint 2007 documents
  • Optional: pdftohtml (free) is required to index and search Adobe PDF documents
  • Optional: PHP's EXIF library (free) is required to index and search images
  • If you're unsure whether your server meets these requirements, simply contact us with your FTP details and we'll check for you free of charge.

* Please note that your knowledge base can be viewed in all common web browsers. Internet Explorer or Firefox is only required for control panel access.