This product was discontinued on July 1st 2012, however all existing customers will continue to receive support as per their maintenance agreement. Learn more.

Interspire Website Publisher Requirements

Interspire Website Publisher is a simple to install (we offer an installation service if needed) and easy to configure PHP web server script. It requires the following:

User Requirements

  • Operating System: Windows, Mac, Unix or Linux
  • Web Browser: Internet Explorer (Windows) or any Gecko based browser such as FireFox or Safari (Windows, Mac, Linux)

Web Server Requirements

  • Operating System: Linux, Unix, or Windows
  • Web Server: Apache Web Server, LigHTTPD, or IIS (with ISAPI Rewrite 3.0 or higher installed)
  • Scripting Language: PHP 5.1.3 or above
  • Database: MySQL 4.1 or above
  • PHP's GD extension with TrueType support (enabled in PHP 5.0 or above)
  • PHP's SimpleXML extension (enabled in PHP 5.0 or above)
  • PHP's DOMDocument extension (enabled in PHP 5.0 or above)
  • PHP's cURL extension or allow_url_fopen support (enabled in PHP 5.0 or above)
  • Mod_rewrite for Apache for search engine friendly links, or ISAPI Rewrite 3.0 or above for Microsoft IIS
  • If you're unsure whether your server meets these requirements, simply contact us with your FTP details and we'll check for you.
* Please note that your website can be viewed by your visitors in all common web browsers. Internet Explorer or Firefox is only required for control panel access.