BigCommerce - Hosted Ecommerce Software by Interspire

Interspire Forum

 
Go Back   Interspire Forum > Interspire Email Marketer Community Forum > Customization and Integration

Reply
 
Thread Tools Display Modes
  #1  
Old 03-11-2008, 09:22 PM
fcatanza + fcatanza is offline
Interspire Customer
 
Join Date: Nov 2007
Posts: 33
Default Anyone have any luck with XML api in 1.4?

Can someone post an example of usage of the XML api for SS 1.4?

What would an example XML file look like that would "do" something be?

I keep getting the "No data hase been given to the XML-API." error...

Please Help!
Reply With Quote
  #2  
Old 03-11-2008, 11:19 PM
Chris S Chris S is offline
Senior Member
 
Join Date: Feb 2004
Posts: 4,642
Default

Hi,

It's looking for $_POST data, if you're supplying something in the GET string or something it won't work.

Here's an example of the xml:

PHP Code:
<xmlrequest>
        <
username>username</username>
        <
usertoken>user_token</usertoken>
        <
requesttype>subscribers</requesttype>
        <
requestmethod>AddSubscriberToList</requestmethod>
        <
details>
                <
emailaddress>email@address.com</emailaddress>
                <
mailinglist>X</mailinglist>
                <
customfields>
                        <
item>
                                <
fieldid>1</fieldid>
                                <
value>First Name Here</value>
                        </
item>
                </
customfields>
        </
details>
</
xmlrequest
It should be obvious what that does

Quote:
Originally Posted by fcatanza
Can someone post an example of usage of the XML api for SS 1.4?

What would an example XML file look like that would "do" something be?

I keep getting the "No data hase been given to the XML-API." error...

Please Help!
Reply With Quote
  #3  
Old 03-12-2008, 01:42 AM
phpuck + phpuck is offline
Interspire Customer
 
Join Date: Dec 2006
Posts: 16
Default

Has there been any bug reports for the 1.4 release. I usually hold off on installing any updates for a couples of weeks until the bugs are ironed out.. should we be expecting a 1.41 update or do Interspire regard this release as fully stable. Anyone...
Reply With Quote
  #4  
Old 03-12-2008, 01:46 AM
Chris S Chris S is offline
Senior Member
 
Join Date: Feb 2004
Posts: 4,642
Default

Hi,

Asking any software package to be completely bug-free is ridiculous - how many times does your computer say "theres an update available" regardless of what operating system you are using.

Sendstudio is no different.

Yes there are bugs (even in 1.3.x) and as people report them we are fixing them.

We are going to try and do either weekly or fortnightly releases for 1.4 bugfixes and will do that for future versions too.

Quote:
Originally Posted by phpuck
Has there been any bug reports for the 1.4 release. I usually hold off on installing any updates for a couples of weeks until the bugs are ironed out.. should we be expecting a 1.41 update or do Interspire regard this release as fully stable. Anyone...
Reply With Quote
  #5  
Old 03-14-2008, 09:52 PM
maddancer + maddancer is offline
Junior Member
 
Join Date: Oct 2007
Posts: 11
Default

I upgraded and have appreciated the new features. I really like the lightbox effects that are now in use as opposed to the old-style popup windows. Nice work, gentlemen. I also liked the new look of the graphs and charts in a few of the reports.

I continue to be convinced that Interspire writes some of the best php software available anywhere.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump