BigCommerce - Hosted Ecommerce Software by Interspire

Interspire Forum

 
Go Back   Interspire Forum > Interspire Website Publisher 5 > News and Product updates

 
 
Thread Tools Display Modes
  #1  
Old 09-21-2009, 08:26 AM
Jordie Jordie is offline
Senior Member
 
Join Date: Jun 2005
Posts: 712
Default Maintenance Version 5.1.4 Released

Today we released Interspire Website Publisher 5.1.4.

This release improves stability with a number of fixes for bugs and some significant optimizations for sites with larger amounts of content.

This version is now available from the Interspire Client Area for those with a valid maintenance contract.

If you're experiencing problems upgrading to, or after upgrading to Interspire Website Publisher 5.1.4 please submit a support ticket from the Interspire Client Area.

Change log for this version:

Code:
# ------------------------------------------------------------------------------
# Changelog for Interspire Website Publisher 5.1.4
# Released 21st September 2009
# ------------------------------------------------------------------------------

* Bug #5882: Editing an existing image block shows "No file was uploaded" error message
* Bug #5887: The URL browser, when opened from the TinyMCE link dialog, opens behind the link dialog
* Bug #5891: When creating new content, the Save & Add button would not show, or would show as disabled
* Bug #5894: Saving new content is slow with lots of lists and content items
* Bug #5899: During the installation wizard, help tips are rendered too far off to the right
* Bug #5904: Newly created content items do not display until the list they are in is re-saved
* Bug #5913: When the URL language variables were changed in IWP 4.5, redirect URLs were not created
* Bug #5915: Placeholders for module content in TinyMCE do not function outside of content
* Bug #5917: Images in gallery slideshows are not scaled as expected
* Bug #5919: The 'tplcond-hideif-1column' class would not work inside of blocks in the styleguide
* Bug #5925: The modal box that is displayed after uploading gallery images is too tall on 1024x768
* Bug #5929: Insert Link in the URL Browser dialog doesn't function from the Menus & Lists section of the control panel
* Bug #5932: When there is a slogan on the Politics template, the page header is shifted to the right
* Bug #5936: Undefined language variable 'DownloadMoreTemplates'
* Bug #5939: The Image Browser would only display 10 galleries
* Bug #5941: Front end caching of absolute URLs causes issues with sites accessed via both internet and LAN addresses
* Bug #5943: The gallery module is overwriting existing URLs with it's own
* Bug #5944: If a content type doesn't have the meta content field, the website title would be used as the meta title
* Bug #5947: Inserting a link from the URL browser doesn't close the modal window
* Bug #5950: HTML custom blocks will cause a page to render blank or with a PHP syntax error if certain characters are used
* Bug #5955: Gallery placeholder for a gallery slideshow in the WYSIWYG wouldn't show if the cover image was a PNG
* Bug #5959: If the importer hasn't been marked as 'finished', viewing an author profile causes an error

Other Fixes:
* Adding optimizations to saving content
* Remove the group by in the view content query unless there is a search / view being loaded. It would slow the query significantly unnecessarily otherwise.

Changed Files: (It is recommended to upload ALL files when upgrading)

	admin/includes/classes/class.categories.php
	admin/includes/classes/class.content.php
	admin/includes/classes/class.contenttypes.php
	admin/includes/classes/class.home.php
	admin/includes/classes/class.importer.php
	admin/includes/classes/class.layout.php
	admin/includes/classes/class.upgrade.php
	admin/includes/importers/importer.iwp45.php
	admin/includes/upgrades/5104
	admin/includes/upgrades/5104/add_contenttypes_expiryoptions.php
	admin/includes/upgrades/5104/add_contenttypes_hidefrommenu.php
	admin/includes/upgrades/5104/add_contenttypes_startdate.php
	admin/includes/upgrades/5104/add_contenttypes_status.php
	admin/includes/upgrades/5104/add_contenttypes_visible.php
	admin/includes/upgrades/5104/gallery_regenerate_cover_images.php
	admin/includes/upgrades/5104/reactivate_calendar_module.php
	admin/includes/upgrades/5104/reactivate_form_module.php
	admin/includes/upgrades/5104/reactivate_gallery_module.php
	admin/includes/upgrades/5104/refresh_events_5104.php
	admin/includes/upgrades/5104/refresh_list_queries_5104.php
	admin/includes/upgrades/5104/update_contenttypes_visibility.php
	admin/includes/upgrades/5104/refresh_category_urls_affected_by_bug_5943.php
	admin/includes/upgrades/5104/refresh_content_urls_affected_by_bug_5943.php
	admin/templates/content.form.tpl
	admin/templates/content.urlbrowser.tpl
	admin/templates/install.form.tpl
	admin/templates/install.schema.tpl
	api/class.cache.php
	api/class.content.php
	api/class.contenttypes.php
	api/class.event.php
	api/class.lists.php
	api/class.styleguide.php
	api/class.template.php
	api/class.validation.php
	api/events/events.categories.php
	api/events/events.template.php
	includes/pages/viewcategory.php
	includes/pages/viewcontent.php
	init.php
	javascript/admin.common.js
	javascript/admin.dashboard.js
	javascript/admin.js
	javascript/compiled.js
	javascript/helptips.js
	javascript/jquery/plugins/jquery.iModal.js
	javascript/jquery/plugins/jquery.window.js
	language/en-US/admin.common.ini
	language/en-US/admin.upgrade.ini
	lib/class.user.php
	lib/common.defines.php
	lib/tiny_mce/editor.html
	lib/tiny_mce/plugins/advimage/editor_plugin.js
	lib/tiny_mce/plugins/iwpinsertlink/editor_plugin.js
	lib/tiny_mce/plugins/iwpinsertlink/editor_plugin_src.js
	modules/calendar/module.calendar.php
	modules/form/module.form.php
	modules/gallery/javascript/admin.gallery.js
	modules/gallery/javascript/admin.gallery.src.js
	modules/gallery/javascript/galleryview/jquery.galleryview-2.0-pack.js
	modules/gallery/javascript/galleryview/jquery.galleryview-2.0.js
	modules/gallery/module.gallery.php
  #2  
Old 09-21-2009, 09:55 PM
ddpWebGuy + ddpWebGuy is offline
Interspire Customer
 
Join Date: May 2009
Location: Northern California
Posts: 47
Default

Hi Jordie!
I've just loaded all the files. Went to the /admin/ and selected the 'Continue' button to upgrade the 31 database processes.

the little clock just keeps spinning and spinning.... should I cancel? Should I load the files again?
  #3  
Old 09-21-2009, 11:24 PM
ddpWebGuy + ddpWebGuy is offline
Interspire Customer
 
Join Date: May 2009
Location: Northern California
Posts: 47
Default upgrading from 5.0.12 to 5.1.4

on my first attempt, after loading all the new files. And selecting 'Continue' for the update in the /admin/ it was taking a really long time, so I canceled.

then I had a bunch of errors on the /lib/mysqldb/mysqldb.php

so then I restored all the 5.0.12 files. and started again.

on my second attempt. It's doing the same thing. It just keeps spinning. But I'm just going to leave it...

is it supposed to take this long?
  #4  
Old 09-22-2009, 12:07 AM
Jordie Jordie is offline
Senior Member
 
Join Date: Jun 2005
Posts: 712
Default

It may need to take a while if you have a lot of content. Just shoot in a support ticket via the client area and I'll take a look, one of the steps could have failed and not been handled properly.
  #5  
Old 09-22-2009, 08:55 PM
ddpWebGuy + ddpWebGuy is offline
Interspire Customer
 
Join Date: May 2009
Location: Northern California
Posts: 47
Default

Thanks Jordie,
just to complete the post. This was resolved by letting it spin for a while, then I eventually canceled out of it. Logged out, logged back in, and then it finished.

On another note. Doesn't the gallery have a lightbox feature? Perhaps I was just confused when I looked at an example screen shot when it was in development.

I just want to make sure that I didn't miss any files in my upgrade.

thanks.
  #6  
Old 10-06-2009, 06:13 AM
TSimondi + TSimondi is offline
Interspire Customer
 
Join Date: Mar 2009
Posts: 6
Default

I just took the plunge and upgraded 5.0.11 to 5.1.4. I too experienced the long delay but on a second try by reloading the page all seemed to go well. I had to rebuild a menu/list item but managed to do that. My problem is that in the old version an Article would call the thickbox javascript but in the new version it does not seem to do that. I have a fair number of articles with pop-up images using thickbox.

How can I get that function back please?

[Added: Never mind. I see in the download package that thickbox is no longer included in the regular javascript so I added an HTML block to the content type in question to load the CSS and JavaScript files when those pages load. All works as before now.]

Last edited by TSimondi; 10-06-2009 at 10:39 PM.. Reason: Found the answer
  #7  
Old 10-13-2009, 11:30 AM
andynotton + andynotton is offline
Interspire Customer
 
Join Date: Sep 2009
Location: UK Bristol
Posts: 9
Default when the next release of maintenance

can you tell me when the next release of the maintenance is as i am waiting for a fix for a site

Thanks

Andy Notton
 

Tags
bug fixes, bugs, maintenance, release, websitepublisher

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump