BigCommerce - Hosted Ecommerce Software by Interspire

Interspire Forum

 
Go Back   Interspire Forum > Interspire Shopping Cart Community Forum > Customization and Integration > Code Modification and Development Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 10-06-2010, 03:39 PM
Imag-e-nation + Imag-e-nation is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 91
Default Sagepay/Protx Form Failure URl Error

Currently using ISC 6.0.14 for a brand new online shop. I am trying to make a test payment to my new sage pay test account but I am receiving an error when trying to make a payment through Interspire shopping cart

This transaction attempt has failed. Please use the Proceed button go back to the web store from which you were purchasing. The details of the failure are given below.

Status: INVALID

Status Detail: 3085 : The FailureURL format is invalid.


I am using 5.5.2 for another online and all worked fine first time.

Any ideas?
Reply With Quote
  #2  
Old 10-07-2010, 09:58 AM
websnail + websnail is offline
Interspire Customer
 
Join Date: Jul 2008
Posts: 1,548
Default

If you could zip up the sagepay module that you are using to info@snailsolutions.co.uk I can take a look to see if you have the latest version.

It's possible you have the old URL's in your code or they've borked something when they changed the code in 6.0.14 but as I'm only on 5.0.6 as my live system I've not seen the problem you experienced as yet.
__________________
ShoppingCartCommunity - Community Forum, Mods, Hacks, Add-ons & a growing KB (was InterspireD)
SnailSolutions Mod Shop - for Royal Mail Adv, Max Chars, Currency Converters, etc...
Web Mollusc appreciation fund (Paypal: info [at] websnail.net)
Reply With Quote
  #3  
Old 10-07-2010, 02:32 PM
websnail + websnail is offline
Interspire Customer
 
Join Date: Jul 2008
Posts: 1,548
Default

Had a look at both your files and about the only thing I can think of that might be causing this is that your ShopPath variable is not quite right somehow.

The code hasn't changed a great deal and shouldn't have affected the failure URL.

Beyond that I found one forum that mentioned something about some pre-loading images causing problems so it's possible that there's some other weirdness going on with your templates...

Basically, nothing I can point definitively to but hopefully something that will allow you to cast the net wider and locate the problem.
__________________
ShoppingCartCommunity - Community Forum, Mods, Hacks, Add-ons & a growing KB (was InterspireD)
SnailSolutions Mod Shop - for Royal Mail Adv, Max Chars, Currency Converters, etc...
Web Mollusc appreciation fund (Paypal: info [at] websnail.net)
Reply With Quote
  #4  
Old 10-07-2010, 02:38 PM
Imag-e-nation + Imag-e-nation is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 91
Default

Thank you Martin

Much appreciated, will have a further look about but ive tried everything that i can think of. May need a fresh install. Since I havent really done too much with the new site its not too much work.

Thank again
Reply With Quote
  #5  
Old 10-07-2010, 02:44 PM
websnail + websnail is offline
Interspire Customer
 
Join Date: Jul 2008
Posts: 1,548
Default

Quote:
Originally Posted by Imag-e-nation View Post
Thank you Martin

Much appreciated, will have a further look about but ive tried everything that i can think of. May need a fresh install. Since I havent really done too much with the new site its not too much work.
You're welcome but just a thought... I'd do a fresh install into a sub-directory on your site and use a different prefix (or better yet, a different database) and see if a fresh/vanilla install has the same issue.

If it does you won't have wasted the time put into your existing 6.0.14 install by overwriting it... and if the problem disappears you can always use something like examdiff to compare the versions to see what's different across the board.

Obviously downloading both the existing and the new/fresh install to compare them is a must, because invariably the version you have locally on your hard drive isn't always mirrored on the web server (something I've found to my cost ... see "ass-u-me" ).
__________________
ShoppingCartCommunity - Community Forum, Mods, Hacks, Add-ons & a growing KB (was InterspireD)
SnailSolutions Mod Shop - for Royal Mail Adv, Max Chars, Currency Converters, etc...
Web Mollusc appreciation fund (Paypal: info [at] websnail.net)
Reply With Quote
  #6  
Old 10-07-2010, 02:53 PM
Imag-e-nation + Imag-e-nation is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 91
Default

Good advise!!!!
Reply With Quote
  #7  
Old 10-07-2010, 07:09 PM
Imag-e-nation + Imag-e-nation is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 91
Default

Tested fresh install of ISC 6.0.14 in subdomain this time i get Success URL failure. ARGGHHHH!!!
Reply With Quote
  #8  
Old 10-11-2010, 02:23 AM
Imag-e-nation + Imag-e-nation is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 91
Default

A complete fresh install of 6.0.14 seemed to fix the problem..
Reply With Quote
  #9  
Old 10-11-2010, 08:47 AM
websnail + websnail is offline
Interspire Customer
 
Join Date: Jul 2008
Posts: 1,548
Default

Quote:
Originally Posted by Imag-e-nation View Post
A complete fresh install of 6.0.14 seemed to fix the problem..
Would be interesting to see what the difference was between the two versions that resulted in that error.

Somehow I have a feeling it's a template or something similar.
__________________
ShoppingCartCommunity - Community Forum, Mods, Hacks, Add-ons & a growing KB (was InterspireD)
SnailSolutions Mod Shop - for Royal Mail Adv, Max Chars, Currency Converters, etc...
Web Mollusc appreciation fund (Paypal: info [at] websnail.net)
Reply With Quote
Reply

Tags
error, failure, sagepay, url

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump