BigCommerce - Hosted Ecommerce Software by Interspire

Interspire Forum

 
Go Back   Interspire Forum > Interspire Website Publisher 5 > Customization and Integration

 
 
Thread Tools Display Modes
  #1  
Old 03-20-2012, 02:48 PM
karks88 + karks88 is offline
Interspire Customer
 
Join Date: Sep 2005
Posts: 15
Default Integrating some custom PHP

Hi, I'm trying to integrate a custom php script into a PHP Block in the Website Layout portion of the admin panel. Basically, it's a PHP image gallery (my client for whatever reason doesn't like the one that comes with IWP). I've been playing with the code, but am getting the following error:

Quote:
Fatal error: Uncaught exception 'ErrorException' with message 'Non-static method iwp_cache::ConfirmDir() should not be called statically, assuming $this from incompatible context' in /usr/home/ekwds77/public_html/goodall/api/class.template.php:379 Stack trace: #0 /usr/home/ekwds77/public_html/goodall/api/class.template.php(379): exception_error_handler(2048, 'Non-static meth...', '/usr/home/ekwds...', 379, Array) #1 /usr/home/ekwds77/public_html/goodall/api/class.template.php(225): iwp_template->ParseTemplate('htmlhead_standa...', true) #2 /usr/home/ekwds77/public_html/goodall/api/class.controller.php(288): iwp_template->ParseSection('htmlhead_standa...') #3 /usr/home/ekwds77/public_html/goodall/includes/pages/viewcontent.php(235): iwp_controller->ShowTemplate('contentitem_231') #4 /usr/home/ekwds77/public_html/goodall/init.php(188): iwp_page_viewcontent->ShowPage('231') #5 /usr/home/ekwds77/public_html/goodall/index.php(14): require_once('/usr/home/ekwds...') #6 {main} thrown in /usr/home/ekwds77/public_html/goodall/api/class.template.php on line 379
This is the code I'm trying to run in the PHP block:

PHP Code:
<?php

require_once "phpgallery/phpgallery/include_phpgallery.php"
?>

<?php
//must declare the gallery and set properties here! for ajax request
$gallery=new PhpGallery();

$gallery->GalleryFolder="phpgallery/goodallphotos"//the path to the image directory
$gallery->AllowEdit=false;            //default is false
$gallery->AllowPostComment=false;    //default is false
$gallery->AllowShowComment=false;    //default is true

//set the user info for comment poster, if not set, the poster will save as guest
$gallery->LogonUserID="test@test.com";       
$gallery->LogonUserName="test";       

//set the resource component option.
$gallery->Layout="Goodall";
$gallery->Editor="Explorer";
$gallery->Slider="NewWin";
$gallery->Viewer="Goodall";
$gallery->Popup="Default";
$gallery->Theme="Goodall";

//handle the ajax request , if any
$gallery->ProcessAjaxPostback();

        
$gallery->Render();

?>
Any ideas as to what may be causing the error?

Last edited by karks88; 03-20-2012 at 06:00 PM..
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump