BigCommerce - Hosted Ecommerce Software by Interspire

Interspire Forum

 
Go Back   Interspire Forum > Interspire Email Marketer Community Forum > Customization and Integration

Reply
 
Thread Tools Display Modes
  #1  
Old 01-01-2018, 10:20 PM
pvb + pvb is offline
Interspire Customer
 
Join Date: Nov 2013
Posts: 15
Default Error When upgraded to PHP 7

My webserver was upgraded to PHP 7 and now I cannot log into my admin panel.

The error is:

Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home1/boyleass/public_html/em6/admin/com/init.php:214 Stack trace: #0 /.../.../public_html/.../admin/index.php(79): require_once() #1 {main} thrown in /.../.../public_html/.../admin/com/init.php on line 214

This is a result of being upgraded to php7 which is required for my other applications and security.

Is there a fix???
Reply With Quote
  #2  
Old 01-10-2018, 12:15 AM
myshop + myshop is offline
Interspire Customer
 
Join Date: Aug 2008
Location: Central Coast, NSW Australia
Posts: 1,340
Default

It doesnt support PHP7
__________________
Thanks
David
Reply With Quote
  #3  
Old 01-10-2018, 01:12 AM
pvb + pvb is offline
Interspire Customer
 
Join Date: Nov 2013
Posts: 15
Default PHP 7 compatibility fix

Through my own research I was able to come up with a fix for this and get Email Marketer 6.1.4 and Send Studio NX1.4.2 to work in a PHP 7 environment by doing the following:

For Email Marketer 6.1.4 you need to create an .htaccess file by opening a text editor and adding this text:

# Use PHP5.6 Single php.ini as default
AddHandler application/x-httpd-phpbetas .php

Save the file as an .htaccess extension and upload to the directory where the program resides.

==============
For those running the legacy Send Studio NX1.4.2 follow the same procedure

except use the following lower php version with this syntax

# Use PHP5.4 as default
AddHandler application/x-httpd-php54 .php:

==============

If your website is running php7 on its root directory and your email system is on a separate folder, you can run two different php versions (php7 on the main site and php 5.6 on a subdirectory) the two will work.
Reply With Quote
  #4  
Old Today, 12:17 AM
maborakprogrammer + maborakprogrammer is offline
Interspire Customer
 
Join Date: Mar 2010
Location: Bolivia
Posts: 95
Send a message via MSN to maborakprogrammer Send a message via Yahoo to maborakprogrammer Send a message via Skype™ to maborakprogrammer
Default

loading.......

Upgrade to version 6.1.8. , all previous versions are hackable and your data is in risk.

connection closed.
__________________
Interspire Addons provided by Maborak Technologies ( https://www.maborak.com ):
--------------------------------------------------------------
Community Forum: Discussion Board
--------------------------------------------------------------
ADDONS: Supported versions: IEM 6.1.3 to 6.1.7 and PHP v7.0
  1. Multiple-MTA(SMTP Rotation) + IP Monitor: Details - Documentation
  2. Multiple-Threads: Increase your sending ratio from interspire to your MTA Server in 400% with 4 threads, 800% with 8 threads.Video Demo
  3. Feedback Loops: Manage your SPAM complaints generated by your subscribers. Screenshot 1
  4. ISP Manager: View and Export your Openners/Clicks/Bounces/Unsubscribers classified by ISP domain.
  5. Advanced Export / backups: Demo
  6. GeoLocation Statistics: Details , Demo , Screenshot 1 Screenshot 2
  7. Social Network Integration: Demo1 Demo2
  8. Spin Content + Remote URL masquerade: Spin your content/subject/mail-from/reply-to/bounce-to/sender-name/Company Address. Demo
  9. PowerMTA Bounce Processor: Process Bounces directly from PowerMTA Log Files. Details
  10. MultiLanguage: Multiple Language Interface at User Level Demo
--------------------------------------------------------------
Email Service Provider Configurations / PowerMTA/SMTP Gateway Consulting Services / Interspire Customizations
Custom Code/Development?: Contact us

Maborak Technologies, Contact us: support@maborak.com
Reply With Quote
  #5  
Old Today, 01:05 AM
myshop + myshop is offline
Interspire Customer
 
Join Date: Aug 2008
Location: Central Coast, NSW Australia
Posts: 1,340
Default

The lastest CVE I can find is: NVD - CVE-2017-14322 - Sept 2017 and covers versions upto 6.1.5.

Are you aware of something newer? If so, please elaborate.

Interspires response to the CVE above was simply negligent (and continues to be)
__________________
Thanks
David
Reply With Quote
Reply

Tags
error, php7

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump