BigCommerce - Hosted Ecommerce Software by Interspire

Interspire Forum

 
Go Back   Interspire Forum > Interspire Shopping Cart Community Forum > Customization and Integration > Layout and Store Design Customization

Reply
 
Thread Tools Display Modes
  #1  
Old 06-29-2011, 05:03 PM
alexrobonline + alexrobonline is offline
Interspire Customer
 
Join Date: Jul 2009
Posts: 13
Default Custom template not showing in admin

Hi guys,

I'm wanting to create a custom template, and I've followed the steps in the Template Customization Guide in copying the "default" folder in /templates/ and re-naming my new folder to something more meaningful.

Unfortunately, when I go to the Store Design section in Admin, there is no listing for my new name. It's all lower case and yes, I've edited the relevant bits of the config.php file in the new directory, to reflect the name.

Also - a side issue - does anyone know where the "panels" and "snippets" files are, within the "default" template? The Template Customization Guide describes these, but I can't see any anywhere!

Thanks, in advance, for any help

Alex
Reply With Quote
  #2  
Old 10-27-2011, 02:25 PM
biggreyhorse + biggreyhorse is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 98
Default

I have followed the above and cant see my folder, can someone tell me what Im doping wrong ?? Thank you
Reply With Quote
  #3  
Old 10-27-2011, 02:37 PM
bigboardroom + bigboardroom is offline
Interspire Customer
 
Join Date: Oct 2011
Posts: 90
Default

When you go into Store Design, are you seeing any templates at all besides Default? If not, safe mode might be on or you might have cURL turned off on the server. Either of those would keep you from seeing your new template as well as all of the other available templates.

I should probably add that even if your server has that issue, you don't necessarily have to fix it. You can manually change the configuration variables for template name and color from within the config.php file at /config/config.php. Though, frankly, lack of cURL on the server is going to cause problems in other areas, so if it's that one, you should fix it.
__________________
BigBoardroom.com - eCommerce Experts and Services. Providing management, design, consulting, and custom development.

Last edited by bigboardroom; 10-27-2011 at 02:39 PM..
Reply With Quote
  #4  
Old 10-27-2011, 03:01 PM
biggreyhorse + biggreyhorse is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 98
Default

I can see all the designs in C panel of interspire. I have navigated to the templates folder on my ftp, added a new folder called mydesign, changed the php file.
Now according to interspire I should be able to see the folder I have created in the c panel.

Any ideas as I had created a custom design, then tried one of the other templates now by folder has gone so I want to upload again ???
Reply With Quote
  #5  
Old 10-27-2011, 03:15 PM
bigboardroom + bigboardroom is offline
Interspire Customer
 
Join Date: Oct 2011
Posts: 90
Default

It definitely works for me. The template system is modular in that it checks that folder (/templates/) for any new folders every time you open an Interspire page. That's what those init.php files are doing for you - opening all of the necessary classes and checking for changes to modular folders like the templates folder.

Maybe your /templates/ folder is set to a CHMOD/permission of 777 and the template search program can't access the folder any more? I'm sure it's something silly like that. I'm not having any problems on any of my servers or local environments adding new templates.

If you can't work it out, you should just download a new template like Infinity and then customize that with your new design.
__________________
BigBoardroom.com - eCommerce Experts and Services. Providing management, design, consulting, and custom development.
Reply With Quote
  #6  
Old 10-27-2011, 03:26 PM
biggreyhorse + biggreyhorse is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 98
Default

Im uploading to folder called /templates is this the correct directory. It has copies of some of the templates I have applied through the C panal, but the c-panal will not show the custum folder I have created aand uploaded I have set all the CHMPD to 0755.

Im desperate to get this custom folder to work. Thanks for your help.
Reply With Quote
  #7  
Old 10-28-2011, 07:32 AM
biggreyhorse + biggreyhorse is offline
Interspire Customer
 
Join Date: Feb 2010
Posts: 98
Default

Can anyone please try and create a folder in the templates folder, then see if the cpanel then picks it up in design mode?

I have followed interspires instructions and cant get it to work.
Reply With Quote
  #8  
Old 10-28-2011, 06:47 PM
bigboardroom + bigboardroom is offline
Interspire Customer
 
Join Date: Oct 2011
Posts: 90
Default

Hi, I'm PM'd you in regards to this. I can do it in my stores no problem.
__________________
BigBoardroom.com - eCommerce Experts and Services. Providing management, design, consulting, and custom development.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump