Interspire Product Knowledge Base

Would you like to...

Print this page Print this page

Email this page Email this page

Post a comment Post a comment

Subscribe me

Add to favorites Add to favorites

Remove Highlighting Remove Highlighting

Edit this Article

Export to PDF

User Opinions (1 vote)

0% thumbs up 100% thumbs down

How would you rate this answer?



Thank you for rating this answer.

I am logged into the control panel with Design Mode enabled, but Design Mode is not visible on my website.

There can be several causes for this, we will attempt to address each one as we find them. Most of the time however, this will come down to a browser- or server-related issue that we are unable to fix for you.


The home page of your control panel has a warning about register_globals.

If PHP is configured to have "register_globals" on, some hosting configurations may refuse to allow design mode to function properly. In this case, you must get register_globals disabled on your site.

For further information, please see this article:

http://www.interspire.com/support/kb/questions/807/How+to+disable%7B47%7Dturn+off+register_globals+for+PHP


Check your PHP's session.save_path setting.


One likely cause is that your PHP installation is configured to save session info at different locations for the front end and control panel, which means when you view the control panel it has no idea that you are logged into the admin, too - so it will not enable design mode for you.

You can test this by creating a file called phpinfo.php and placing inside it the following two lines of code:

<?php
phpinfo();


Upload this file to the base of your Website Publisher installation, and also into the admin folder. Then, run the file using your web browser by going to:

http://www.yourwebsite.com/phpinfo.php

And:

http://www.yourwebsite.com/admin/phpinfo.php

There will be a lot of technical info visible on these two pages, but if you search the page (usually CTRL-F) for "session.save_path" you will find the relevant info. The value for session.save_path should be exactly the same for both pages. If it is not, please consult with your hosting provider on how to correct this issue. Sorry, but we cannot correct this for you.

Once you have finished, you may then safely delete the two copies of phpinfo.php you have uploaded.

Related Articles

No related articles were found.

Attachments

No attachments were found.

Powered by Interspire Knowledge Manager - World's #1 Best Selling FAQ and Knowledge Base Software