Interspire Product Knowledge Base

Would you like to...

Print this page Print this page

Email this page Email this page

Post a comment Post a comment

Subscribe me

Add to favorites Add to favorites

Remove Highlighting Remove Highlighting

Edit this Article

Export to PDF

User Opinions (7 votes)

42% thumbs up 57% thumbs down

How would you rate this answer?



Thank you for rating this answer.

URLs not working, Page Not Found or 404 Errors on an Apache web-server

his article is for running Interspire Interspire Website Publisher 5.0+ on an Apache Webserver. If you are using an Apache Webserver, continue reading below.

Why the URLs aren't working

Interspire Interspire Website Publisher uses special Search Engine Friendly (SEF) URLs for your site. It does this using a server application called "mod_rewrite". Sometimes the default configuration Website Publisher provides to mod_rewrite needs to be altered for the URLs/links to work.


Running Interspire Interspire Website Publisher in a sub-folder?

A common problem is that with some users who wish to place Interspire Interspire Website Publisher in a subfolder, they find their links broken. This is because the .htaccess file is looking in the wrong place for applicaton. To fix this, simply open up the .htaccess file (it will be located in your base Interspire Website Publisher directory) with notepad or another text editor (not MS Word or any other rich text editor) and find near the top:

RewriteEngine On

Now place this following command on a new line after the one above:

RewriteBase /your-sub-directory/

Make sure that you replace your-sub-directory with the name of the sub-directory you have Interspire Interspire Website Publisher running in. Save it, upload and see if your links work. Should they not, contact your host and ensure that they have mod_rewrite enabled for Apache and that they allow you to have this in your .htaccess file:

Options FollowSymLinks -MultiViews
RewriteEngine On


Running Interspire Interspire Website Publisher in your base folder, not a sub-folder?

Open up your .htaccess file (located in the base folder) and find:

RewriteEngine On
Then add in this line just below it:

RewriteBase /

Upload your changes and see if that has fixed your URL problems.

If that doesn't work, send in a support ticket from your client area and note that you have tried this method already.

Related Articles

No related articles were found.

Attachments

No attachments were found.

Powered by Interspire Knowledge Manager - World's #1 Best Selling FAQ and Knowledge Base Software