Interspire Product Knowledge Base

Would you like to...

Print this page Print this page

Email this page Email this page

Post a comment Post a comment

Subscribe me

Add to favorites Add to favorites

Remove Highlighting Remove Highlighting

Edit this Article

Export to PDF

User Opinions (6 votes)

83% thumbs up 16% thumbs down

How would you rate this answer?



Thank you for rating this answer.

Why can I only upload files that are smaller than 2 Megs ?

2 megs is the default limit imposed by php in its configuration file (php.ini) . To increase this you will need to locate your php.ini file. The most reliable way to do this is to create a file on your server with the contents

<?php phpinfo(); ?>

and save the file as say phpinfo.php then go to this page in a web browser.

Near the top of the page you will see a section that says configuration file path. If this is set to a directory you will need to create a php.ini file in this directory to be able to change any settings. If it is a file then this is the file you need to change settings in.

To increase the maximum file size, you will need to adjust the upload_max_filesize setting. Depending on how much you change this it may also be necessary to increase the post_max_size setting.

After these changes you will have to restart your web server for the changes to take effect.

Finally if you are running Apache you may need to find a setting in Apache's configuration files (usually httpd.conf) that sets the LimitRequestBody to allow the increase. As far as I am aware this is only set by default with Apache2 under Fedora but if the previous changes don't help it might be worth checking this out.

Related Articles

No related articles were found.

Attachments

No attachments were found.

Powered by Interspire Knowledge Manager - World's #1 Best Selling FAQ and Knowledge Base Software