Interspire Product Knowledge Base

Would you like to...

Print this page Print this page

Email this page Email this page

Post a comment Post a comment

Subscribe me

Add to favorites Add to favorites

Remove Highlighting Remove Highlighting

Edit this Article

Export to PDF

User Opinions (23 votes)

69% thumbs up 30% thumbs down

How would you rate this answer?



Thank you for rating this answer.

URLs not working, or 404 Errors from Interspire Website Publisher links on an Apache web-server

This article is for running Interspire Website Publisher on an Apache Webserver. If you are using a Windows IIS Server, click here. If you are using an Apache Webserver, continue reading below.

Why the URLs aren't working

Interspire Website Publisher uses a special Search Engine Friendly (SEF) URLs for your site by "rewriting" them.

For example, instead of having a URL like:

http://www.myarticlesite.com/category.php?id=34245&title=My Category&page=3
the URL rewriting converts them to this:

http://www.myarticlesite.com/category/My-Category/page/3/
Some servers or situations mean the default Interspire Website Publisher installation will not work straight away.

The Apache web-server has a module called mod_rewrite which allows us to rewrite the URLs to our script files. To make these URLs function correctly there is a file called ".htaccess" included with the Interspire Website Publisher zip. This file sets the "rewrite rules" for Interspire Website Publisher.

Running Interspire Website Publisher in a sub-folder?

A common problem we have found is that with some users who wish to place Interspire Website Publisher in a subfolder, they find their links "broken". This is because the .htaccess file is looking in the wrong place for the file to point to. To fix this, simply open up the .htaccess file (it will be located in your base Interspire Website Publisher directory) with notepad or another text editor (not MS Word or any other "rich text" editor) and find near the top:

RewriteEngine On
Now place this following command on a new line after the one above:

RewriteBase /your-sub-directory/
Make sure that you replace your-sub-directory with the name of the sub-directory you have Interspire Website Publisher running in. Save it, upload and see if your links work. Should they not, contact your host and ensure that they have mod_rewrite enabled for Apache and that they allow you to have this in your .htaccess file:

Options FollowSymLinks -MultiViews
RewriteEngine On

Running AL in your base folder, not a sub-folder?

Open up your .htaccess file (located in the base folder) and find:

RewriteEngine On
Then add in this line just below it:

RewriteBase /
Upload your changes and see if that has fixed your URL problems.


If that doesn't work, send in a support ticket from your client area and note that you have tried this method already.

Getting an 'Internal Server Error'?
This error usually comes up as a result of the .htaccess file attempting to use a command it is not allowed to. If you edit the file and remove this line:

Options -MultiViews FollowSymlinks
as well as:


# Turn off mod_security filtering.
SecFilterEngine Off

# The below probably isn't needed, but better safe than sorry.
SecFilterScanPOST Off

Then save and see if that fixes your problem. If it doesn't, contact your host and make sure they allow .htaccess files and have mod_rewrite enabled.

If you are having further troubles, and your host insists that you have the correct permissions, contact us through a support ticket via your client area and we will assist you in fixing this problem.

Powered by Interspire Knowledge Manager - World's #1 Best Selling FAQ and Knowledge Base Software