Interspire Product Knowledge Base

Would you like to...

Print this page Print this page

Email this page Email this page

Post a comment Post a comment

Subscribe me

Add to favorites Add to favorites

Remove Highlighting Remove Highlighting

Edit this Article

Export to PDF

User Opinions (0 votes)

No users have voted.

How would you rate this answer?



Thank you for rating this answer.

I get an error about session_start() at the top of every page

If you get the an error like

Notice: A session had already been started - ignoring session_start() in C:\wwwroot\example.com\web\shop\admin\init.php on line 7

at the top of each page. Then you either have session.auto_start on or have an auto_prepend file set to a file with a session_start() in it in your php.ini file.

Interspire Shopping Cart needs to start it's own sessions to work properly so you need to disable these settings in the php.ini file. On Windows this is normally location in C:\PHP or C:\Windows

You need to edit the php.ini file and set session.auto_start to 1 and make sure the auto_prepend_file is empty. After doing this you may need to restart your web server to have the change take affect.

Related Articles

No related articles were found.

Attachments

No attachments were found.

Powered by Interspire Knowledge Manager - World's #1 Best Selling FAQ and Knowledge Base Software